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ตัวอยางการใช Keil uVision3 ในการสราง Project File ของ Keil ARM 
 ในทีน่ี้จะขอแสดงแนวทางการเขียนโปรแกรมภาษาซี โดยใช Keil-CARM ในการแปลคําสั่ง ภายใต
โปรแกรม Text Editor ของ Keil (Keil uVision3) โดยจะขออธิบายถงึเฉพาะวธิีการกาํหนดคา Option สําหรับ
เชื่อมโยงคําสัง่ในการสั่งแปลโปรแกรมดวย Keil-CARM ผานทาง Keil uVision3 เทานัน้ สวนรายละเอียดคําสั่งและ
การใชงานฟงกชั่นตางๆในการเขียนโปรแกรมของ Keil-CARM นั้นขอใหผูใชศึกษาจากคูมือคําสัง่ของ Keil-CARM 
เอง โดยวิธกีารกําหนดคาตวัเลือกของ Keil uVision3 ใหใชงานกับ Keil-CARM นัน้มีข้ันตอนพอสังเขปดังนี้คือ 
 
1. เปดโปรแกรม Keil uVision3 ซึ่งเปนโปรแกรม Text Editor ของ Keil-CARM ใชสําหรับใชในการเขียนโปรแกรมที่
เปน Source Code ภาษาซ ีโดยจะมีลักษณะดังรูป 

 

 
 
2. ทําการกําหนดคาตัวเลือกในการแปลคําสั่งของ uVision3 ใหใชงานกบัโปรแกรม Keil uVision3 และ Keil-CARM 
โดยใหเลือกคลิกเมาสที่เมนคํูาสั่ง Project → Components ,Environment, Books… จากนัน้ใหเลือกคาตวัเลือก
สําหรับกาํหนดการใชงาน Complier จากหัวขอ Select ARM Development Tools ซึ่งจะมีคาตัวเลือกอยู 3 แบบ 
คือ Use Keil-CARM Tools ,Use GNU Tools และ Use ARM Tools โดยใหเลือกเปน “Use Keil ARM Tools”  
จากนั้นใหทาํการกําหนดตําแหนง Folder สําหรับเก็บคาตัวเลือกการทํางานของโปรแกรม Keil ARM ซึ่งตามปรกติ
แลวจะเปน “C:\Keil\ARM\” แตถาติดตั้ง Keil ไวที่อ่ืนกต็องปรับเปลี่ยนใหถกูตองตามความเปนจริงดวยดงัรูป 
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3. ทาํการสราง Project File ข้ึนมาใหม โดยเรียกเมนูคําสั่ง Project → New Project จากนัน้ใหเลือกกาํหนดหรือ
สรางตําแหนง Folder ที่จะบันทกึ Project File พรอมกับกําหนดชื่อ Project File ตามตองการ เชน ถาตองการสราง 
Project File ชือ่ DEMO1 โดยเก็บไวใน Folder ชื่อ DEMO1 ก็สามารถกําหนดตําแหนง Folder และชื่อ Project File 
ไดเอง โดยเมือ่กําหนดชื่อในชอง File name แลวใหเลือก Save เพื่อบันทกึ Project File ไว ดังรูป 
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หลังจากกาํหนดชื่อและสั่ง Save Project File แลว โปรแกรมจะรอใหผูใชทาํการกาํหนด เบอร MCU ที่จะ
ใชงานใน Project ที่ส่ัง Save นั้น ซึ่งในกรณีที่ใชงานกบับอรด ET-BASE2103 นั้น ใหเลือกกาํหนดเบอรของ MCU 
เปน LPC2103 ของ Philips แลวเลือก OK ดังรูป 
 

 
 

 หลังจากเลือกกําหนดเบอรของ MCU เปนทีเ่รียบรอยแลว ในขัน้ตอนนี้โปรแกรมจะรอใหผูใชยืนยนัวา
ตองการจะทําการ Copy ไฟล Startup ของ Keil เพื่อใชงานกับ MCU ของ Philips มาใชใน Project ดวยหรือไม โดย 
Startup ไฟลจะเปนสวนของการกาํหนดคาเริ่มตนการทาํงานใหกับ MCU เชน การกําหนดคา Stack และการ
กําหนดค าการทํางานใหกับ Phase-Lock-Loop ตางๆ กอนที่จะเร่ิมตนทํางานตามโปรแกรมที่เราเขยีนขึ้น ไมเชนนั้น
แลวโปรแกรมที่เราเขียนขึ้นมานัน้จะตองเพิ่มคําสัง่ในการเตรียมการทาํงานสวนเหลานี้ให MCU เองทัง้หมด  

แตเนื่องจากไฟล Startup ของ Keil-ARM นั้น เปนไฟลภาษาแอสแซมบลี้ ซึ่งกําหนดคาการทาํงานไวกับชุด
พัฒนาของ Keil เอง ดังนั้นขอกําหนดและการกาํหนดคาบางอยางจะมีความแตกตางกนัอยูกับคาที่ตองการสาํหรับ 
บอรด “ET-BASE2103” ไมสามารถใชงานไฟล Startup ไดทันท ีตองมีการแกไขคาตัวเลือกใหม ดังนั้นกอนที่จะใช
โปรแกรม Keil-CARM ในการแปลคําสั่งใหนัน้ ผูใชจะตองเขาไปแกไขไฟล Startup ใหมโดยตองกาํหนดรูปแบบให
ถูกตองตรงกับความตองการของบอรด “ET-BASE2103” ดวย ดังนัน้ในทีน่ี้ขอแนะนําใหเลือก “No” เพื่อไมให Keil 
uVision3 ทําการ Copy ไฟล Startup ของ Keil-CARM มาใชใน Project นี้ดวย  
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4. ใหทําการ Copy File ชื่อ “Startup.s” ที่ทาง อีทีท ี จัดเตรียมไวใน CD-ROM ซึ่งเก็บไวใน Example ชื่อ 
“Startup.s” มาไวในตําแหนง Folder เดียวกันกับ Project File ที่สรางขึ้นมาใหมนี ้ 

โดยไฟล “Startup.s” จะเปนไฟลซึง่บรรจุคําสั่งภาษาแอสแซมบลี้ของ ARM7 สําหรับทาํหนาทีก่ําหนดคา
เร่ิมตนการทํางานที่จาํเปนใหกับ MCU ซึ่งไดแกการ กําหนดคา Stack ใหกับ MCU การ Initial Phase-Lock-Loop 
การกําหนดคาใหกับ MAM Function และการกาํหนดตําแหนง Vector ตางๆของ MCU สําหรับใชงานรวมกบับอรด 
“ET-BASE2103” ซึ่งถาสั่ง Add ไฟล “Startup.s” จาก Keil หรือ Copy ไฟลดังกลาวมาจากแหลงอื่นๆ อาจมกีาร
ทํางานของโปรแกรมใน Startup ไมเหมือนกนั ซึง่จะสงผลตอการทํางานของโปรแกรมที่จะเขียนขึน้ดวย 

 
5. ใหทําการกาํหนดคา Option ของ Project File โดยเลือกเมนูคําสั่ง Project → Option for Target ’Target 1’ 
จากนั้นเลือกที ่Tab ของ Target เพื่อกําหนดคาของ MCU Target โดยใหกําหนดดังนี ้

5.1 X-TAL ใหกําหนดเปน 19.6608 MHz พรอมกับเลือกกําหนดใหใชหนวยความจาํที่มีอยูใน MCU เปน
เงื่อนไขในการแปลโปรแกรมของ Keil-CARM ดวย ดังรูป 
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5.2 Output ใหเลือกคลิกเมาสทีค่าตัวเลือก Create HEX File พรอมกับเลอืกกําหนดรูปแบบของ Hex ให
เปนแบบ HEX-386 แลวเลือก OK ดังรูป 

 

  
 

6. เร่ิมตนเขียน Source Code ภาษาซ ีโดยใหเลือกคลิกเมาสทีเ่มนูคําสั่ง File → New… ซึ่งจะไดพื้นที่ในการเขยีน 
Text File เกิดขึ้นมา โดยในครั้งแรกจะกําหนดชื่อตามคา Default เปน “Text1” ดังรูป 
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 ในขั้นตอนนี้ใหทาํการพิมพ Source Code ภาษาซ ีตามขอกําหนดของ Keil-CARM ในพืน้ที่เขียนโปรแกรม
ตามตองตองการดังตัวอยาง 
 
/*****************************************************/ 
/* Examples Program For "ET-ARM7 BASE LPC2103" Board */ 
/* Target MCU  : Philips ARM7-LPC2103                */ 
/*             : X-TAL : 19.6608 MHz                 */ 
/*             : Run Speed 58.9824MHz (With PLL)     */ 
/* Keil Editor : uVision3 V3.03a                     */ 
/* Compiler    : Keil CARM V2.50a               */ 
/* Function    : Example LED Blink on GPIO0[31]      */ 
/*****************************************************/ 
 
#include <LPC2103.H>               // LPC2103 MPU Register 
 
/* pototype  section */ 
void delay(unsigned long int); // Delay Time Function 
 
int main(void) 
{    
  PINSEL0 = 0x00000000;   // Makesure GPIO0 = I/O Function 
  PINSEL1 = 0x00000000;    
  IODIR   = 0x80000000;    // Set GPIO-0[31] = Output 
  IOSET   = 0x80000000;            // Set GPIO-0[31] Pin (OFF LED)   
  
  // Loop Test Output GPI0-0  
  while(1)     // Loop Continue 
  {       
 IOCLR = 0x80000000;   // Clear GPIO0[31] Pin (ON LED) 
     delay(10000000);   // Display Delay 
 IOSET = 0x80000000;           // Set GPIO0[31] Pin (OFF LED)   
     delay(10000000);   // Display Delay 
  }   
}    
 
/***********************/ 
/* Delay Time Function */ 
/*    1-4294967296     */ 
/***********************/ 
void delay(unsigned long int count1) 
{ 
  while(count1 > 0) {count1--;} // Loop Decrease Counter  
} 

 
ตัวอยางโปรแกรมไฟกระพริบ 1 ดวง ที่ GPIO0.31 
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 หลังจากพิมพคําสั่งภาษาซีเสร็จเรียบรอยตามตองการแลว ใหส่ัง Save ไฟลดังกลาว โดยตองกาํหนดเปน
ไฟลที่มนีามสกุลเปน “.C” ในทีน่ี้ขอแนะนําใหส่ัง Save โดยใชคําสัง่ File → Save As… แลวกําหนดชือ่และ
นามสกุลของไฟลเปน .main.c” ดังรูป 
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 ซึ่งหลงัจากที่ส่ัง Save ไฟลเปน “main.c” แลวจะเหน็วาลักษณะสีของตัวอักขระตางๆในโปรแกรมจะเกิด
การเปลี่ยนแปลงไปตามหนาที่ เชน  Comment, ตัวแปร และ คําสั่ง เปนตน ซึง่สวนนี้เปนขอดีของ Keil uVision3 ซึ่ง
สามารถแยกและแสดงตัวอักขระไดอยางเปนหมวดหมู ทาํใหงายตอการอานโปรแกรมดวย ดังรูป 

 

 
 
7. ทําการสัง่ Add File ตางๆเขากับ Project File โดยใหเลือกคลิกเมาสที่คําสั่ง Project → Components, 
Environment, Books… จากนัน้ใหเลือกที ่Tab Project Components แลวเลือกที่ Add File ที่ตองการจะเพิ่มเขา
ไปใชงานรวมกับ Project File 

โดยในครั้งแรกใหเลือก Files of type เปน “C Source files(*.c)” ซึง่จะปรากฏชื่อไฟลตางๆทีเ่ปน Source 
Code ภาษาซใีหเหน็ โดยในที่นี้ใหเลือกคลกิเมาสที่ไอคอนของไฟลชื่อ “main.c” แลวเลือก Add เพื่อส่ังเพิ่มไฟลชื่อ 
“Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 
 จากนั้นใหเลือกกําหนด File of type ใหมเปน “ASM Source files(*.s*;*.src;*.a*) ซึ่งจะปรากฏชื่อของไฟล 
Startup.s ใหเห็นในชองแสดงชื่อไฟล ใหทําการคลิกเมาสที่ไอคอนของไฟล “Startup.s” แลวเลือก Add เพื่อส่ังเพิ่ม
ไฟลชื่อ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว  
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 เมื่อทําการสัง่ Add ไฟลชื่อ “main.c’ และ “Startup.s” ใหกับ Project File เปนทีเ่รียบรอยแลวใหเลือกที่ 
Close เพื่อเปนการสิน้สุดการสั่ง Add File ซึ่งจะไดดังรูป 
 

 
 
↓ 
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↓ 
 

 
 
 ซึ่งหลงัจากทาํการสั่ง Add File ทั้ง “main.c” และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลว จะ
สังเกตเห็นที่ชอง Tab ของ File ปรากฏชื่อของ File ทั้ง 2 ใหเห็นดวย 
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8. ใหทําการสัง่แปลโปรแกรมที่เราเขียนขึน้เรียบรอยแลว โดยใหคลิกเมาสที่เมนูคําสั่ง Projects → Rebuild all 
target files ซึ่งโปรแกรม Keil uVision3 จะทําการสั่งใหโปรแกรม Keil-CARM ทําการแปลคําสั่งใหทันท ี

 

 
 

 ซึ่งหลงัจากสั่งแปลโปรแกรมแลวไดผลถูกตองและไมเกิดขอผิดพลาดใดๆขึ้น (0 Error และ 0 Warning) ก็
ได Hex File ซึ่งมีชื่อเหมือนกันกับชื่อของ Project File ที่สรางไว ซึง่ผูใชสามารถนาํ Hex File ดังกลาวไปทําการ 
Download ใหกับ MCU ไดทันท ี
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ขอแนะนําในการ Initial MCU กอนเริ่มตนการทาํงานของโปรแกรมหลกั 
 เพื่อใหการทาํงานของ MCU มีประสิทธิภาพสงูสุด ทัง้ในดานของความเร็วในการประมวลผลคําสัง่ และการ
ทํางานควรกาํหนดคาตางๆใหกับ MCU ดังตอไปนี ้

- ควรกําหนดคา PLL ใหไดคา Processor Clock (cclk) = 58.9824MHz โดยในกรณีที่ใชคา XTAL เปน 
19.6608MHz ตองใหคา M(Multiply)=3 และ P(Divide)=2 และ FFCO =235.9296MHz 

- ควรกําหนดคา VPB Clock (pclk) ใหมีคา เปนครึ่งหนึ่งของ cclk หรือ 29.4912MHz 
- ควรกําหนดคา MAM Timing ใหมีคา 3 Cycle ของ cclk (MAMTIM = 0x03) 
- ควรกําหนดคา MAM Mode เปน Full Enable (MAMCR = 0x02) 
โดยการกาํหนดคาตางๆดังกลาวขางตนนัน้ สามารถทาํได 2 วิธีคือ การเขียน Code คําสั่งในโปรแกรมที่เรา

เขียนขึ้นเองทัง้หมด หรือใชการ Copy ไฟลที่เปน Startup File ที่สรางไวเรียบรอยแลวมาใชงาน จากนั้นจงึสั่ง Add 
Startup File เขามาใชงานใน Project ที่เราสรางขึน้ ซึง่การตรวจสอบและแกไขคาของ Startup File นัน้ สามารถทํา
ได 2 แบบ คือ เขาไปแกไข Code คําสั่งในไฟลตามความตองการ หรือ ใชการกาํหนดคา Startup File จากหนาตาง
โปรแกรมของ Keil uVision3 เอง ซึ่งเพื่อใหเกิดความสะดวกตอการใชงานขอแนะนาํใหใชวธิีการแกไขเปลี่ยนแปลง
คาจาก Keil uVision3 จะดีที่สุด  
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การตรวจสอบคา Startup File 
 หนาที่ของ Startup File คือ บรรจุคําสั่งของโปรแกรมเริ่มตนการทํางานของ MCU กอนทีจ่ะเริ่มตนมา

ทํางานตามคาํสั่งที่เราเขียนขึน้ โดยโปรแกรมที่อยูใน Startup ไฟลจะทาํหนาที ่ Initial การทาํงานของ MCU ในสวน
ที่จําเปนกอน จากนั้นจงึจะกระโดดไปทํางานตามคําสั่งในโปรแกรมภาษาซทีี่เราเขียนขึ้น ซึง่การเขาไปตรวจสอบคา
ของ Startup ไฟลสามารถทาํไดโดย ใหเลอืกคลิกที ่Tab ของไฟล Startup แลวเลือก “Expand All” ซึ่งจะเหน็คาที่
กําหนดไวใน Startup File ดังรูป 
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แสดงการกําหนดคา Startup File สําหรับ LPC2103 
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ตัวอยาง Code ภาษาซีของ Keil-CARM สําหรับ Initial การทาํงานของ LPC2103 
 สําหรับในกรณีที่ตองการเขียนโปรแกรม Initial การทํางานของ MCU เอง ก็สามารถทาํได โดยการเพิ่ม 
Code คําสั่งเขาไปในสวนเริ่มตนการทํางานของ Main Program ดังตัวอยาง 
 

// Initial PLL & VPB Clock For ET-BASE2103 
// Start of Initial PLL for Generate Processor Clock  
// PLL Configuration Setup 
// X-TAL = 19.6608MHz   
// M(Multiply) = 3 
// P(Divide) = 2 
// Processor Clock(cclk) = M x OSC  
//                       = 3 x 19.6608MHz  
//                       = 58.9824MHz 
// FCCO = cclk x 2 x P 
//      = 58.9824 x 2 x P 
//      = 235.9296 MHz 
// VPB Clock(pclk) = 29.4912MHz 
// Start of Initial PLL for Generate Processor Clock  
PLLCFG &= 0xE0;    // Reset MSEL0:4 
PLLCFG |= 0x02;    // MSEL(PLL Multiply) = 3 
PLLCFG &= 0x9F;    // Reset PSEL0:1 
PLLCFG |= 0x20;    // PSEL(PLL Devide) = 2 
 
PLLCON &= 0xFC;    // Reset PLLC,PLLE 
PLLCON |= 0x01;    // PLLE = 1 = Enable PLL 
  
PLLFEED = 0xAA;    // Start Update PLL Config 
PLLFEED = 0x55; 
while (!(PLLSTAT & 0x00000400));  // Wait PLL Lock bit 
  
PLLCON |= 0x02;    // PLLC = 1 (Connect PLL Clock) 
PLLFEED = 0xAA;     // Start Update PLL Config 
PLLFEED = 0x55; 
 
VPBDIV &= 0xFC;    // Reset VPBDIV 
VPBDIV |= 0x02;    // VPB Clock(pclk) = cclk / 2 
// End of Initial PLL for Generate Processor Clock  
   
// Start of Initial MAM Function 
MAMCR = 0x00;     // Disable MAM Function 
MAMTIM = 0x03;     // MAM Timing = 3 Cycle of cclk 
MAMCR = 0x02;     // Enable MAM = Full Function 
// End of Initial MAM Function 
 
// Start of Main Function Here 
. 

 
แสดงตัวอยาง Code สําหรับ Initial การทํางานของ LPC2103 กอนเริ่มตนทํางานใน Main โปรแกรม 


