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การพัฒนาโปรแกรม ET-ARM STAMP LPC2119 ดวย GCCARM รวมกับ Editor ของ Keil uVision3  
 
 ในการพัฒนาโปรแกรมของ ARM7 ดวย GCCARM นั้น ตามปรกตแิลว GCCARM จะเปนเพียงโปรแกรม 
C-Complier อยางเดยีว ไมมีสวนของโปรแกรม Text Editor รวมอยูดวย ดังนัน้ในการสราง Source Code จะตอง
ใชโปรแกรมจําพวก Text Editor ตัวอื่นๆในการสราง Source Code ที่เปน Text File แลวบันทึกเปนไฟลภาษาซีไว 
จากนั้นจงึใช GCCARM ในการสั่งแปลคําสั่ง (Complier) อีกครั้งหนึ่ง โดยในการสัง่ Complier นัน้จะเปนการสั่งงาน
แบบ Command Line โดยผูใชจะตองเขาใจรูปแบบคําสั่งและ Option ตางๆในการสั่ง Complier เปนอยางดีจงึจะ
สามารถสัง่ Complier ไดอยางถูกตองตามเงื่อนไขที่ตองการ ซึ่งจะเหน็ไดวาการใชงานโปรแกรม GCCARM นั้นจะ
ไมคอยมีความสะดวกมากนัก เนื่องจากตองสลับการทํางานของโปรแกรมจาก Text Editor ไปยัง Command Line 
เพื่อส่ังแปลโปรแกรม ซึ่งถาเกิดขอผิดพลาดขึ้นก็จะตองกลับเขาไปแกไข Source Code นั้นใหม แลวกลับไปส่ังแปล
โปรแกรมใหมอีก โดยอาจตองวนเวียนอยูเชนนี้หลายๆรอบ จนกวาโปรแกรมที่เขยีนขึ้นนัน้จะเสร็จสมบูรณ แต
อยางไรก็ดี GCCARM ก็มขีอดี ที่ทุกคนปฏิเสธไมได คือ เปนของฟรี ซึ่งสามารถ Download มาใชไดโดยไมเสีย
คาใชจายใดๆ ถึงแมวาจะมีขอจํากัดในเรื่องของความสะดวกสบายในการใชงานอยูบางก็ตาม  
 สําหรับในกรณีที่ผูใชมีชุดโปรแกรม Keil-ARM รุน Demo สําหรับทดลองใชงานอยูแลวนัน้ สามารถ อาศัย
โปแกรม Text Editor ของ Keil-ARM (Keil uVision3) สําหรับเขยีน Source Code ภาษาซี แลวกาํหนดการ
เชื่อมโยง Command Line ใหไปเรียกใชโปรแกรม GCCARM ในการแปลคําสั่งแทนได ซึ่งจะทาํใหผูใชงานสามารถ
ทําการเขียนโปรแกรมภาษาซีและสั่งแปลโปรแกรมไดจากหนาเมนูคําสั่งของโปรแกรม Keil uVision3 ไดเชนเดยีวกัน
การใช Keil-ARM ทุกประการ เพยีงแตวา ขอกําหนดในการเขียนโปรแกรม Source Code ที่เปนภาษาซนีัน้ จะตอง
ยึดหลักการเขยีนโปรแกรมตามรูปแบบและขอกําหนดของ GCCARM แทนเทานัน้ ซึง่ขอดีของการใช GCCARM ก็
คือ ไมมีขอจํากัดในเรื่องขนาดของ Output Hex File เหมือนการใช Keil-ARM รุนทดลองใช(Demo) 
 
ขอแนะนําในการใชงานโปรแกรม 
    - โปรแกรม Keil-ARM รุน Demo สามารถ Download ไดจาก WWW.KEIL.COM โดยในการติดตัง้ใชงาน
นั้น เพื่อใหสะดวกตอการกาํหนดคาตวัเลือกใชงานตางๆขอแนะนําใหติดตั้งโปรแกรมใน Folder ชื่อ C:\keil ตาม
คาตัวเลือกที่เปนคา Default ของโปรแกรมติดตั้งจะดีทีสุ่ด 
  - โปรแกรม GCCARM สามารถ Download ไดจาก WWW.KEIL.COM เชนเดยีวกนั โดยในการติดตั้งใช
งานนัน้ขอแนะนําใหติดตั้งโปรแกรมไวใน Folder ชื่อ C:\Cygnus ตามคาตัวเลือกที่เปนคา Default ของโปรแกรม
ติดตั้งจะดีที่สุด เพราะจะงายในการสั่งกาํหนดคา Option ตางๆในการใชงาน 

เนื่องจากถาตดิตั้งโปรแกรมใน Folder ที่แตกตางไปจากนี้แลว ผูใชตองทาํการปรับแกตําแหนง Folder ใน
ข้ันตอนของการกําหนดคาตัวเลือกในโปรแกรมใหมตามที่ติดตั้งโปรแกรมไวจริงดวยจะไมสามารถอางองิตาม
คําแนะนํานี้ไดทั้งหมด 
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การใช Keil uVision3 รวมกับ GCCARM Complier 
 ในทีน่ี้จะขอแสดงแนวทางการเขียนโปรแกรมภาษาซ ี โดยใช GCCARM ในการแปลคําสั่ง ภายใตโปรแกรม 
Text Editor ของ Keil (Keil uVision3) โดยจะขออธิบายถงึเฉพาะวธิีการกาํหนดคา Option สําหรับเชื่อมโยงคําสั่ง
ในการสัง่แปลโปรแกรมดวย GCCARM ผานทาง Keil uVision3 ของ Keil เทานั้น สวนรายละเอียดคําสั่งและการใช
งานฟงกชัน่ตางๆในการเขียนโปรแกรมของ GCCARM นั้นขอใหผูใชศึกษาจากคูมือคําสั่งของ GCCRAM เอง โดย
วิธีการกําหนดคาตัวเลือกของ Keil uVision3 ใหใชงานกบั GCCARM นั้นมีข้ันตอนพอสังเขปดังนี้คือ 
 
1. เปดโปรแกรม Keil uVision3 ซึ่งเปนโปรแกรม Text Editor ของ Keil-ARM ใชสําหรับใชในการเขียนโปรแกรมที่
เปน Source Code ภาษาซ ีโดยจะมีลักษณะดังรูป 

 

 
 
2. ทาํการกาํหนดคาตัวเลือกในการแปลคําสั่งของ uVision3 ใหใชงานกบัโปรแกรม Keil uVision3 และ GCCARM 
โดยใหเลือกคลิกเมาสที่เมนคํูาสั่ง Project → Components ,Environment, Books… จากนัน้ใหเลือกคาตวัเลือก
สําหรับกาํหนดการใชงาน Complier จากหัวขอ Select ARM Development Tools ซึ่งจะมีคาตัวเลือกอยู 3 แบบ 
คือ Use Keil ARM Tools ,Use GNU Tools และ Use ARM Tools โดยใหเลือกเปน “Use GNU Tools”  จากนั้นให
เลือกกําหนดตําแหนง Folder ที่ไดทําการติดตั้งโปรแกรมไว ซึ่งตามปรกติแลวถาติดตั้งโปรแกรม GCCARM ตามคา 
Default จะอยูที่ C:\Cygnus… ซึ่งจะไดดังรูป (ถาติดตั้งโปรแกรมตางไปจากนี้ใหแกไขตามความเปนจริงดวย) 
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3. ทาํการสราง Project File ข้ึนมาใหม โดยเรียกเมนูคําสั่ง Project → New Project จากนัน้ใหเลือกกาํหนดหรือ
สรางตําแหนง Folder ที่จะบันทกึ Project File พรอมกับกําหนดชื่อ Project File ตามตองการ เชน ถาตองการสราง 
Project File ชื่อ EX1 โดยเก็บไวใน Folder ชื่อ EX1 ก็สามารถกําหนดตําแหนง Folder และชื่อ Project File ไดเอง 
โดยเมื่อกาํหนดชื่อในชอง File name แลวใหเลือก Save เพื่อบันทึก Project File ไว ดังรูป 

 

 
 



ตัวอยางการพัฒนาโปรแกรมของบอรด ET-ARM STAMP LPC2119 ดวย GCCARM รวมกับ Keil uVision3    

การพัฒนาโปรแกรม GCCARM ดวย Keil uVision3 -4- WWW.ETT.CO.TH 
 

หลังจากกาํหนดชื่อและสั่ง Save Project File แลว โปรแกรมจะรอใหผูใชทาํการกาํหนด เบอร MCU ที่จะ
ใชงานใน Project ที่ส่ัง Save นั้น ซึ่งในกรณีที่ใชงานกับบอรด ET-ARM STAMP LPC2119 นั้น ใหเลือกกาํหนด
เบอรของ MCU เปน LPC2119 ของ Philips แลวเลือก OK ดังรูป 
 

 
 

 ในขั้นตอนนี้โปรแกรมจะรอใหผูใชยืนยันวาตองการจะทาํการ Copy ไฟล Startup เพื่อใชงานกบั MCU ของ 
Philips มาใชใน Project ดวยหรือไม โดย Startup ไฟลจะเปนสวนของการกาํหนดคาเริ่มตนการทาํงานใหกับ MCU 
เชน การกําหนดคา Stack และการกําหนด ค าการทาํงานใหกับ Phase-Lock-Loop ตางๆ กอนที่จะเริ่มตนทาํงาน
ตามโปรแกรมที่เราเขียนขึ้น ไมเชนนั้นแลวโปรแกรมที่เราเขียนขึ้นมานัน้จะตองเพิ่มคําสัง่ในการเตรียมการทาํงาน
สวนเหลานี้ให MCU เองทัง้หมด  

แตเนื่องจากไฟล Startup ของ Keil-ARM นั้น เปนไฟลภาษาแอสแซมบลี้ ซึ่งทั้ง Keil-ARM และ GCCARM 
นั้น จะใชโปรแกรมแอสแซมเบอรตางกนั ดังนัน้ขอกําหนดและรูปแบบไวยากรณทางดานการกําหนดคาบางอยางจะ
มีความแตกตางกนัอยูไมสามารถใชงานไฟล Startup รวมกันได ดังนั้นในการที่จะใชโปรแกรม GCCARM ในการ
แปลคําสั่งใหนั้น ผูใชจะตองสรางไฟล Startup ใหมโดยตองกําหนดรูปแบบใหถูกตองกับที่ GCCARM กําหนดไว 
ดังนัน้ในที่นี้จะตองเลือก “No” เพื่อไมให Keil uVision3 ทําการ Copy ไฟล Startup ของ Keil-ARM มาใชใน 
Project นี้ดวย เนื่องจากรูปแบบของคําสั่งแตกตางกนัและใชงานรวมกนัไมได 
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4. ใหทาํการ Copy File ชื่อ “Flash.ld” และ “Startup.S” ที่ทาง อีททีี จัดเตรียมไวใน CD-ROM ซึ่งเก็บไวใน Folder 
ชื่อ “SOURCE_GCC” มาไวในตําแหนง Folder เดียวกนักับ Project File ที่สรางขึน้มาใหมนี ้ 

โดยไฟล “Flash.ld” จะเปน Script File ซึ่งใชเก็บคาตัวเลือกสาํหรับกําหนดคาตําแหนงเริ่มตนและสิ้นสุด 
รวมทัง้ขนาดของหนวยความจํา Flash และ RAM ที่มอียูจริงภายในตัวของ MCU เบอร LPC2119 ของ Philips ซึ่ง
เปน MCU ที่ใชกับบอรด ET-ARM STAMP LPC2119 โดยคาตางๆทีก่ําหนดไวใน Script File ตัวนี้จะใชเพื่อบอกให
โปรแกรม Keil uVision3 ทราบวาจะตองกําหนดเงื่อนไขการแปลคําสั่งใหกับ GCCARM อยางไรบาง ซึ่งถากาํหนด
เงื่อนไขไมถูกตองแลว HEX File ที่ไดจากการแปลคําสั่งก็จะเกิดความผิดพลาดตามไปดวย  

สวนไฟล “Startup.S” จะเปนไฟลซึง่บรรจุคําสั่งภาษาแอสแซมบลี้ของ ARM7 สําหรับทําหนาที่กําหนดคา
เร่ิมตนการทํางานที่จาํเปนใหกับ MCU ซึ่งไดแกการ กําหนดคา Stack ใหกับ MCU การ Initial Phase-Lock-Loop 
การกําหนดคาใหกับ MAM Function และการกําหนดตําแหนง Vector ตางๆของ MCU 

 
5. ใหทําการกาํหนดคา Option ของ Project File โดยเลือกเมนูคําสั่ง Project → Option for Target ’Target 1’ 
จากนั้นเลือกที ่Tab ของ Target เพื่อกําหนดคาของ MCU Target โดยใหกําหนดดังนี ้

5.1 X-TAL ใหกําหนดเปน 19.6608 MHz 
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5.2 Output ใหเลอืกคลิกเมาสทีค่าตัวเลือก Create HEX File  

 
 

5.3 Linker ใหเลอืกคลิกเมาสทีตั่วเลือก Enable Garbage Collection และ Do not use Standard 
System Startup Files สวน Linker Script File นั้นใหเลอืกกําหนดเปน “Flash.ld” โดยคลิกเมาสที่ปุม
คําสั่ง […] ที่อยูระหวางชองแสดงชื่อ Script File และปุมคําสั่ง “Edit…” จากนั้นก็ใหคลิกเมาสที่ไอคอน
ของไฟล “Flash.ld” แลวเลือก Open ซึ่งจะปรากฏชื่อของ Script File ดังกลาวในชองแสดงชือ่ของ 
Script File ทนัท ี

 
 

กําหนด 
Script 
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↓ 
 

 
 

 หลังการทาํการกําหนด Script File ใหกับ Project เปนทีเ่รียบรอยแลว ในขั้นตอนถัดไปใหทาํการกําหนดคา
ตําแหนงแอดเดรสเริ่มตนของหนวยความจําที่จะใชในการเก็บโปรแกรมและขอมูล โดยในกรณีของ LPC2119 ใหทาํ
การกําหนดคาเปนดังนี ้

- Text Start ใหกําหนดเปน 0x0000 0000 
- Data Start ใหกําหนดเปน 0x4000 0000 

 
ซึ่งจะสงัเกตเหน็วาโปรแกรม Keil uVision3 จะแสดง Option ในการแปลคําสั่งใหเราทราบดวยทางชอง

แสดงคาของ Linker Control String โดยคาจะเปลี่ยนแปลงไปตามการกําหนดเงื่อนไขของเราดังรูป 
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6. เร่ิมตนเขียน Source Code ภาษาซ ีโดยใหเลือกคลิกเมาสทีเ่มนูคําสั่ง File → New… ซึ่งจะไดพื้นที่ในการเขยีน 
Text File เกิดขึ้นมา โดยในครั้งแรกจะกําหนดชื่อตามคา Default เปน “Text1” ดังรูป 
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 ในขั้นตอนนี้ใหทาํการพิมพ Source Code ภาษาซ ีตามขอกําหนดของ GCCARM ในพืน้ที่เขียนโปรแกรม
ตามตองตองการดังตัวอยาง 
 
/*****************************************************/ 
/* Examples Program For "ET-ARM STAMP LPC2119" Board */ 
/* Target MCU  : Philips ARM7-LPC2119                */ 
/*           : X-TAL : 19.6608 MHz                   */ 
/*             : Run Speed 58.9824MHz (With PLL)     */ 
/* Compiler    : GCC ARM V3.31                 */ 
/* Last Update : 1/September/2005                    */ 
/* Function    : Example Use GPIO-1on Output Mode    */ 
/*             : LED Blink on GPIO1.16               */ 
/*****************************************************/ 
 
#include <LPC21xx.H>            // LPC2119 MPU Register 
 
/* pototype  section */ 
void delay_led(unsigned long int); // Delay Time Function 
 
int main(void) 
{   
  PINSEL2 &= 0xFFFFFFFC;   // Set GPIO1.16 = GPIO Function 
  IODIR1   = 0x00010000;   // Set GPIO1.16 = Output 
  IOSET1   = 0x00010000;           // Set GPIO1.16 Pin (OFF LED) 
 
  // Loop Blink LED on GPIO1.16 // 
  while(1)     // Loop Continue 
  { 
     IOCLR1 = 0x00010000;  // Clear Pin P1.16 (ON LED) 
 delay_led(1500000);      // Display LED Delay 
 IOSET1 = 0x00010000;          // Set Pin P1.16 (OFF LED)      
 delay_led(1500000);   // Display LED Delay 
  }    
}    
 
/***********************/ 
/* Delay Time Function */ 
/*    1-4294967296     */ 
/***********************/ 
void delay_led(unsigned long int count1) 
{ 
  while(count1 > 0) {count1--;} // Loop Decrease Counter  
} 
 

ตัวอยางโปรแกรมไฟกระพริบ 1 ดวง ที่ GPIO1.16 
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 หลังจากพิมพคําสั่งภาษาซีเสร็จเรียบรอยตามตองการแลว ใหส่ัง Save ไฟลดังกลาว โดยตองกาํหนดเปน
ไฟลที่มนีามสกุลเปน “.C” ในทีน่ี้ขอแนะนําใหส่ัง Save โดยใชคําสัง่ File → Save As… แลวกําหนดชือ่และ
นามสกุลของไฟลเปน .main.c” ดังรูป 
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 ซึ่งหลงัจากที่ส่ัง Save ไฟลเปน “main.c” แลวจะเหน็วาลักษณะสีของตัวอักขระตางๆในโปรแกรมจะเกิด
การเปลี่ยนแปลงไปตามหนาที่ เชน  Comment, ตัวแปร และ คําสั่ง เปนตน ซึง่สวนนี้เปนขอดีของ Keil uVision3 ซึ่ง
สามารถแยกและแสดงตัวอักขระไดอยางเปนหมวดหมู ทาํใหงายตอการอานโปรแกรมดวย ดังรูป 
 

 
 
7. ทําการสัง่ Add File ตางๆเขากับ Project File โดยใหเลือกคลิกเมาสที่คําสั่ง Project → Components, 
Environment, Books… จากนัน้ใหเลือกที ่Tab Project Components แลวเลือกที่ Add File ที่ตองการจะเพิ่มเขา
ไปใชงานรวมกับ Project File 

โดยในครั้งแรกใหเลือก Files of type เปน “C Source files(*.c)” ซึง่จะปรากฏชื่อไฟลตางๆทีเ่ปน Source 
Code ภาษาซใีหเหน็ โดยในที่นี้ใหเลือกคลกิเมาสที่ไอคอนของไฟลชื่อ “main.c” แลวเลือก Add เพื่อส่ังเพิ่มไฟลชื่อ 
“Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 
 จากนั้นใหเลือกกําหนด File of type ใหมเปน “ASM Source files(*.s*;*.src;*.a*) ซึ่งจะปรากฏชื่อของไฟล 
Startup.s ใหเห็นในชองแสดงชื่อไฟล ใหทําการคลิกเมาสที่ไอคอนของไฟล “Startup.s” แลวเลือก Add เพื่อส่ังเพิ่ม
ไฟลชื่อ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว  
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 เมื่อทําการสัง่ Add ไฟลชื่อ “main.c’ และ “Startup.s” ใหกับ Project File เปนทีเ่รียบรอยแลวใหเลือกที่ 
Close เพื่อเปนการสิน้สุดการสั่ง Add File ซึ่งจะไดดังรูป 

 
 
↓ 
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↓ 
 

 
 
 ซึ่งหลงัจากทาํการสั่ง Add File ทั้ง “main.c” และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลว จะ
สังเกตเห็นที่ชอง Tab ของ File ปรากฏชื่อของ File ทั้ง 2 ใหเห็นดวย 
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8. ใหทําการสัง่แปลโปรแกรมที่เราเขียนขึน้เรียบรอยแลว โดยใหคลิกเมาสที่เมนูคําสั่ง Projects → Rebuild all 
target files ซึ่งโปรแกรม Keil uVision3 จะทําการสั่งใหโปรแกรม GCCARM ทําการแปลคําสั่งใหทันท ี

 

 
 

 ซึ่งหลงัจากสั่งแปลโปรแกรมแลวไดผลถูกตองและไมเกิดขอผิดพลาดใดๆขึ้น (0 Error และ 0 Warning) ก็
ได Hex File ซึ่งมีชื่อเหมือนกันกับชื่อของ Project File ที่สรางไว ซึง่ผูใชสามารถนาํ Hex File ดังกลาวไปทําการ 
Download ใหกับ MCU ไดทันท ี
 
ขอแนะนําในการ Initial MCU กอนเริ่มตนการทาํงานของโปรแกรมหลกั 
 เพื่อใหการทาํงานของ MCU มีประสิทธิภาพสงูสุด ทัง้ในดานของความเร็วในการประมวลผลคําสัง่ และการ
ทํางานควรกาํหนดคาตางๆใหกับ MCU ดังตอไปนี ้

- ควรกําหนดคา PLL ใหไดคา Processor Clock (cclk) = 58.9824MHz โดยในกรณีที่ใชคา XTAL เปน 
19.6608MHz ตองใหคา M(Multiply)=3 และ P(Divide)=2 และ FFCO =235.9296MHz 

- ควรกําหนดคา VPB Clock (pclk) ใหมีคา เปนครึ่งหนึ่งของ cclk หรือ 29.4912MHz 
- ควรกําหนดคา MAM Timing ใหมีคา 3 Cycle ของ cclk (MAMTIM = 0x03) 
- ควรกําหนดคา MAM Mode เปน Full Enable (MAMCR = 0x02) 
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โดยการกาํหนดคาตางๆดังกลาวขางตนนัน้ สามารถทาํได 2 วิธีคือ การเขียน Code คําสั่งในโปรแกรมที่เรา
เขียนขึ้นเองทัง้หมด หรือใชการ Copy ไฟลที่เปน Startup File และ Script File ที่สรางไวเรียบรอยแลวมาใชงาน 
จากนั้นจงึสั่ง Add Startup File และ Script File เขามาใชงานใน Project ที่เราสรางขึ้น ซึ่งการตรวจสอบและแกไข
คาของ Startup File และ Script File นั้น สามารถทําได 2 แบบ คือ เขาไปแกไข Code คําสั่งในไฟลตามความ
ตองการ หรือ ใชการกําหนดคา Startup File และ Script File จากหนาตางโปรแกรมของ Keil uVision3 เอง ซึง่
เพื่อใหเกิดความสะดวกตอการใชงานขอแนะนาํใหใชวธิีการแกไขเปลี่ยนแปลงคาจาก Keil uVision3 จะดีที่สุด  
 
การตรวจสอบคา Startup File 

 หนาที่ของ Startup File คือ บรรจุคําสั่งของโปรแกรมเริ่มตนการทํางานของ MCU กอนทีจ่ะเริ่มตนมา
ทํางานตามคาํสั่งที่เราเขียนขึน้ โดยโปรแกรมที่อยูใน Startup ไฟลจะทาํหนาที ่ Initial การทาํงานของ MCU ในสวน
ที่จําเปนกอน จากนั้นจงึจะกระโดดไปทํางานตามคําสั่งในโปรแกรมภาษาซทีี่เราเขียนขึ้น ซึง่การเขาไปตรวจสอบคา
ของ Startup ไฟลสามารถทาํไดโดย ใหเลอืกคลิกที ่Tab ของไฟล Startup แลวเลือก “Expand All” ซึ่งจะเหน็คาที่
กําหนดไวใน Startup File ดังรูป 
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แสดงการกําหนดคา Startup File สําหรับ LPC2119 
 

การตรวจสอบ Script File 
 สําหรับหนาทีข่อง Script File นัน้จะใชเกบ็คาที่กาํหนดตําแหนงและขนาดของหนวยความจําใน MCU หรือ 
Target บอรดที่จะใชกับโปรแกรมที่เราเขียนขึ้น โดยในกรณีที่ใช LPC2119 นัน้ จะมขีนาดของหนวยความจํา Code 
Flash ขนาด 128K โดยมีตําแหนงเริ่มตนอยูที ่ 00000000H-0001FFFFH สวนหนวยความจาํ Data RAM จะมี
ขนาด 16KByte โดยมีตําแหนงอยูที่ 40000000H-40003FFFH ซึ่งใน Script File ชื่อ “Flash.ld” ที่จัดทาํไวใน
ตัวอยางภาษาซี ของ GCCARM โดยอีททีี นัน้จะกําหนดคา Configuration ของหนวยความจําไวอยางถกูตอง
สําหรับ LPC2119 อยูแลว แตถามีการเขาไปแกไขหรือเปลี่ยนแปลงคาเปนอยางอื่นอาจทาํใหโปรแกรมที่ไดจากการ
แปลคําสั่งของ GCCARM ไมสามารถทาํงานไดอยางถกูตอง โดยการตรวจสอบคาความถกูตองของ Configuration 
ใน Script File สามารถทําไดโดยการสั่ง Open ไฟล ชือ่ “Flash.ld” ซึ่งอยูใน Folder เดียวกันกบั Project File ดวย
โปรแกรม Keil uVision3 หรือถามกีารสัง่ Open File ไวอยูแลวใหเลือก Tab ของไฟลไปยัง “Flash.ld” แลว
เลือก”Expand All” จากนัน้ใหตรวจสอบคาตางๆดูวาเปนไปตามที่กําหนดไวหรือไม ซึ่งคาที่ถกูตองจะตองเปนดงัรูป 
 

 
 

แสดงการกําหนดคา Script File สําหรบั LPC2119 
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ตัวอยาง Code ภาษาซีของ GCCARM สําหรบั Initial การทํางานของ LPC2119 
 สําหรับในกรณีที่ตองการเขียนโปรแกรม Initial การทํางานของ MCU เอง ก็สามารถทาํได โดยการเพิ่ม 
Code คําสั่งเขาไปในสวนเริ่มตนการทํางานของ Main Program ดังตัวอยาง 
 

// Initial PLL & VPB Clock For ET-ARM7 STAMP LPC2119 
// Start of Initial PLL for Generate Processor Clock  
// PLL Configuration Setup 
// X-TAL = 19.6608MHz   
// M(Multiply) = 3 
// P(Divide) = 2 
// Processor Clock(cclk) = M x OSC  
//                       = 3 x 19.6608MHz  
//                       = 58.9824MHz 
// FCCO = cclk x 2 x P 
//      = 58.9824 x 2 x P 
//      = 235.9296 MHz 
// VPB Clock(pclk) = 29.4912MHz 
// Start of Initial PLL for Generate Processor Clock  
PLLCFG &= 0xE0;    // Reset MSEL0:4 
PLLCFG |= 0x02;    // MSEL(PLL Multiply) = 3 
PLLCFG &= 0x9F;    // Reset PSEL0:1 
PLLCFG |= 0x20;    // PSEL(PLL Devide) = 2 
 
PLLCON &= 0xFC;    // Reset PLLC,PLLE 
PLLCON |= 0x01;    // PLLE = 1 = Enable PLL 
  
PLLFEED = 0xAA;    // Start Update PLL Config 
PLLFEED = 0x55; 
while (!(PLLSTAT & 0x00000400));  // Wait PLL Lock bit 
  
PLLCON |= 0x02;    // PLLC = 1 (Connect PLL Clock) 
PLLFEED = 0xAA;     // Start Update PLL Config 
PLLFEED = 0x55; 
 
VPBDIV &= 0xFC;    // Reset VPBDIV 
VPBDIV |= 0x02;    // VPB Clock(pclk) = cclk / 2 
// End of Initial PLL for Generate Processor Clock  
   
// Start of Initial MAM Function 
MAMCR = 0x00;     // Disable MAM Function 
MAMTIM = 0x03;     // MAM Timing = 3 Cycle of cclk 
MAMCR = 0x02;     // Enable MAM = Full Function 
// End of Initial MAM Function 
 
// Start of Main Function Here 
. 

 
แสดงตัวอยาง Code สําหรับ Initial การทํางานของ LPC2119 กอนเริ่มตนทํางานใน Main โปรแกรม 


