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ตัวอยางการใช Keil uVision3 ในการสราง Project File ของ Keil ARM 
  

ในที่นี้จะขอแสดงแนวทางการเขียนโปรแกรมภาษาซี โดยใช Keil-CARM ในการแปลคําสั่ง ภายใต
โปรแกรม Text Editor ของ Keil (Keil uVision3) โดยจะขออธิบายถึงเฉพาะวิธีการกําหนดคา Option สําหรับ
เชื่อมโยงคําสั่งในการสั่งแปลโปรแกรมดวย Keil-CARM ผานทาง Keil uVision3 เทานั้น สวนรายละเอียดคําสั่ง
และการใชงานฟงกช่ันตางๆในการเขียนโปรแกรมของ Keil-CARM นั้นขอใหผูใชศึกษาจากคูมือคําสั่งของ 
Keil-CARM เอง โดยวิธีการกําหนดคาตัวเลือกของ Keil uVision3 ใหใชงานกับ Keil-CARM นั้นมีขั้นตอนพอ
สังเขปดังนี้คือ 
1. เปดโปรแกรม Keil uVision3 ซ่ึงเปนโปรแกรม Text Editor ของ Keil-CARM ใชสําหรับใชในการเขียน

โปรแกรมที่เปน Source Code ภาษาซี โดยจะมีลักษณะดงัรูป 
 

 
 

2. ทําการกําหนดคาตัวเลือกในการแปลคําสั่งของ uVision3 ใหใชงานกับโปรแกรม Keil uVision3 และ Keil-
CARM โดยใหเลือกคลิกเมาสที่เมนูคําสั่ง Project → Components ,Environment, Books… จากนั้นใหเลือก
คาตัวเลือกสําหรับกําหนดการใชงาน Complier จากหวัขอ Select ARM Development Tools ซ่ึงจะมีคา
ตัวเลือกอยู 3 แบบ คือ Use Keil-CARM Tools ,Use GNU Tools และ Use ARM Tools โดยใหเลือกเปน 
“Use Keil ARM Tools”  จากนั้นใหทําการกําหนดตําแหนง Folder สําหรับเก็บคาตัวเลือกการทํางานของ
โปรแกรม Keil ARM ซ่ึงตามปรกติแลวจะเปน “C:\Keil\ARM\” แตถาติดตั้ง Keil ไวที่อ่ืนก็ตองปรับเปลี่ยน
ใหถูกตองตามความเปนจริงดวยดังรูป 
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3. ทําการสราง Project File ขึ้นมาใหม โดยเรียกเมนูคําสั่ง Project → New Project จากนั้นใหเลือกกําหนด

หรือสรางตําแหนง Folder ที่จะบันทกึ Project File พรอมกับกําหนดชื่อ Project File ตามตองการ เชน ถา
ตองการสราง Project File ช่ือ DEMO1 โดยเก็บไวใน Folder ช่ือ DEMO1 ก็สามารถกําหนดตําแหนง Folder 
และชื่อ Project File ไดเอง โดยเมื่อกําหนดชื่อในชอง File name แลวใหเลือก Save เพื่อบันทึก Project File 
ไว ดังรูป 
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หลังจากกําหนดชื่อและสั่ง Save Project File แลว โปรแกรมจะรอใหผูใชทําการกําหนด เบอร MCU ที่
จะใชงานใน Project ที่ส่ัง Save นั้น ซ่ึงในกรณีที่ใชงานกับบอรด ET-ARM7 LPC2114 นั้น ใหเลือกกําหนดเปน 
MCU ของ Philips เบอร LPC2114 แลวเลือก OK ดังรูป 

 

 
 

 หลังจากเลือกกําหนดเบอรของ MCU เปนที่เรียบรอยแลว ในขั้นตอนนี้โปรแกรมจะรอใหผูใชยนืยันวา
ตองการจะทําการ Copy ไฟล Startup ของ Keil เพื่อใชงานกับ MCU ของ Philips มาใชใน Project ดวยหรือไม 
โดย Startup ไฟลจะเปนสวนของการกําหนดคาเริ่มตนการทํางานใหกบั MCU เชน การกําหนดคา Stack และ
การกําหนดค าการทํางานใหกับ Phase-Lock-Loop ตางๆ กอนที่จะเริ่มตนทํางานตามโปรแกรมที่เราเขียนขึ้น 
ไมเชนนัน้แลวโปรแกรมที่เราเขียนขึ้นมานั้นจะตองเพิ่มคําสั่งในการเตรียมการทํางานสวนเหลานี้ให MCU เอง
ทั้งหมด  

แตเนื่องจากไฟล Startup ของ Keil-ARM นั้น เปนไฟลภาษาแอสแซมบลี้ ซ่ึงกําหนดคาการทํางานไวกับ
ชุดพัฒนาของ Keil เอง ดังนั้นขอกําหนดและการกําหนดคาบางอยางจะมีความแตกตางกันอยูกบัคาที่ตองการ
สําหรับ บอรด “ET-ARM7 LPC2114” ไมสามารถใชงานไฟล Startup ไดทันที ตองมีการแกไขคาตัวเลือกใหม 
ดังนั้นกอนที่จะใชโปรแกรม Keil-CARM ในการแปลคําสั่งใหนั้น ผูใชจะตองเขาไปแกไขไฟล Startup ใหมโดย
ตองกําหนดรูปแบบใหถูกตองตรงกับความตองการของบอรด “ET-ARM7 LPC2114” ดวย ดังนั้นในที่นี้ขอ
แนะนําใหเลือก “No” เพื่อไมให Keil uVision3 ทําการ Copy ไฟล Startup ของ Keil-CARM มาใชใน Project นี้
ดวย  
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4. ใหทําการ Copy File ช่ือ “Startup.s” ที่ทาง อีทีที จัดเตรียมไวใน CD-ROM ซ่ึงเก็บไวใน Example ช่ือ 
“Startup.s” มาไวในตําแหนง Folder เดียวกันกับ Project File ที่สรางขึ้นมาใหมนี้  

โดยไฟล “Startup.s” จะเปนไฟลซ่ึงบรรจุคําสั่งภาษาแอสแซมบลี้ของ ARM7 สําหรับทําหนาที่
กําหนดคาเริ่มตนการทํางานที่จําเปนใหกับ MCU ซ่ึงไดแกการ กําหนดคา Stack ใหกับ MCU การ Initial 
Phase-Lock-Loop การกําหนดคาใหกับ MAM Function และการกําหนดตําแหนง Vector ตางๆของ MCU 
สําหรับใชงานรวมกับบอรด “ET-ARM7 LPC2114” ซ่ึงถาสั่ง Add ไฟล “Startup.s” จาก Keil หรือ Copy 
ไฟลดังกลาวมาจากแหลงอื่นๆ อาจมีการทํางานของโปรแกรมใน Startup ไมเหมือนกัน ซ่ึงจะสงผลตอการ
ทํางานของโปรแกรมที่จะเขียนขึ้นดวย 

 
5.  ใหทําการกําหนดคา Option ของ Project File โดยเลือกเมนูคําสั่ง Project → Option for Target ’Target 1’ 
จากนั้นเลือกที ่Tab ของ Target เพื่อกําหนดคาของ MCU Target โดยใหกําหนดดังนี้ 

5.1 X-TAL ใหกําหนดเปน 19.6608 MHz พรอมกับเลือกกาํหนดใหใชหนวยความจําทีม่ีอยูใน MCU 
เปนเงื่อนไขในการแปลโปรแกรมของ Keil-CARM ดวย ดังรูป 
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5.2 Output ใหเลือกคลิกเมาสที่คาตัวเลือก Create HEX File พรอมกับเลือกกาํหนดรูปแบบของ Hex ให
เปนแบบ HEX-386 แลวเลือก OK ดังรูป 

 

 
 

6. เร่ิมตนเขียน Source Code ภาษาซี โดยใหเลือกคลิกเมาสที่เมนูคําสั่ง File → New… ซ่ึงจะไดพืน้ที่ในการ
เขียน Text File เกิดขึ้นมา โดยในครั้งแรกจะกําหนดชื่อตามคา Default เปน “Text1” ดังรูป 

 

 



ตัวอยางการพัฒนาโปรแกรมของบอรด ET-JR ARM7 LPC2214 ดวย Keil-CARM   

ETT CO., LTD. -6- WWW.ETT.CO.TH 
 

 ในขั้นตอนนี้ใหทําการพิมพ Source Code ภาษาซี ตามขอกําหนดของ Keil-CARM ในพื้นที่เขยีน
โปรแกรมตามตองตองการดงัตัวอยาง 
 
/******************************************************/ 
/* Examples Program For "ET-JR ARM7 LPC2214" Board       */ 
/* Target MCU  : Philips ARM7TDMI-S LPC2214           */ 
/*             : X-TAL: 19.6608 MHz                   */ 
/*              : Run Speed 58.9824MHz (With PLL)      */ 
/* Compiler    : Keil ARM V2.32a           */ 
/* Last Update : 15/05/2006                   */ 
/* Function     : Example Use GPIO-1 on Output Mode  */ 
/*              : LED Blink on GPIO1.16                */  
/******************************************************/ 
 
#include <LPC22xx.H>                 // LPC2214 MPU Register 
 
/* prototype section */ 
void delay_led(unsigned long int);   // Delay Time Function 
 
int main(void) 
{   
  PINSEL2 &= 0xFFFFFFFC;       // Makesure GPIO1.16 = GPIO 
Function 
  IODIR1   = 0x00010000;        // Set GPIO1.16 = Output 
  IOSET1   = 0x00010000;          // Set GPIO1.16 Output Pin (OFF 
LED) 
 
  // Loop Blink LED on GPIO1.16 // 
  while(1)           
  // Loop Continue 
  { 
    IOCLR1 = 0x00010000;      // Clear Output Pin P1.16 (ON LED) 
 delay_led(1500000);           
  // Display LED Delay 
 IOSET1 = 0x00010000;           // Set Output Pin P1.16 (OFF LED)
      
 delay_led(1500000);        
  // Display LED Delay 
  }    
}    
 
/***********************/ 
/* Delay Time Function */ 
/*    1-4294967296     */ 
/***********************/ 
void delay_led(unsigned long int count1) 
{ 
  while(count1 > 0) {count1--;}    // Loop Decrease Counter  
} 

 

ตัวอยางโปรแกรมไฟกระพริบ 1 ดวง ท่ี GPIO1.16 
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 หลังจากพิมพคําสั่งภาษาซีเสร็จเรียบรอยตามตองการแลว ใหส่ัง Save ไฟลดังกลาว โดยตองกาํหนด
เปนไฟลที่มีนามสกุลเปน “.C” ในที่นี้ขอแนะนําใหส่ัง Save โดยใชคําสั่ง File → Save As… แลวกําหนดชื่อ
และนามสกุลของไฟลเปน “main.c” ดังรูป 
 

  
 
 ซ่ึงหลังจากทีส่ั่ง Save ไฟลเปน “main.c” แลวจะเหน็วาลักษณะสีของตัวอักขระตางๆในโปรแกรมจะ
เกิดการเปลีย่นแปลงไปตามหนาที่ เชน Comment, ตัวแปร และ คาํสั่ง เปนตน ซ่ึงสวนนี้เปนขอดีของ Keil 
uVision3 ซ่ึงสามารถแยกและแสดงตวัอักขระไดอยางเปนหมวดหมู ทาํใหงายตอการอานโปรแกรมดวย ดังรูป 
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7. ทําการสั่ง Add File ตางๆเขากับ Project File โดยใหเลือกคลิกเมาสที่คําสั่ง Project → Components, 

Environment, Books… จากนั้นใหเลือกที่ Tab Project Components แลวเลือกที่ Add File ที่ตองการจะเพิ่ม
เขาไปใชงานรวมกับ Project File 

โดยในครั้งแรกใหเลือก Files of type เปน “C Source files(*.c)” ซ่ึงจะปรากฏชื่อไฟลตางๆที่เปน 
Source Code ภาษาซีใหเหน็ โดยในที่นีใ้หเลือกคลิกเมาสที่ไอคอนของไฟลช่ือ “main.c” แลวเลือก Add เพื่อ
ส่ังเพิ่มไฟลช่ือ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 

จากนั้นใหเลือกกําหนด File of type ใหมเปน “ASM Source files(*.s*;*.src;*.a*) ซ่ึงจะปรากฏชื่อ
ของไฟล Startup.s ใหเห็นในชองแสดงชือ่ไฟล ใหทําการคลิกเมาสที่ไอคอนของไฟล “Startup.s” แลวเลือก 
Add เพื่อส่ังเพิ่มไฟลช่ือ “Startup.s” เขาไปรวมกับ Project Files ที่เราสรางไว 

เมื่อทําการสั่ง Add ไฟลช่ือ “main.c’ และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลวให
เลือกที่ Close เพื่อเปนการสิน้สุดการสั่ง Add File ซ่ึงจะไดดังรูป 
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↓ 
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↓ 
 

 
 

ซ่ึงหลังจากทําการสั่ง Add File ทั้ง “main.c” และ “Startup.s” ใหกับ Project File เปนที่เรียบรอยแลว จะ
สังเกตเห็นที่ชอง Tab ของ File ปรากฏชื่อของ File ทั้ง 2 ใหเห็นดวย 
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8. ใหทําการสั่งแปลโปรแกรมที่เราเขียนขึ้นเรียบรอยแลว โดยใหคลิกเมาสที่เมนูคําสั่ง Projects → 
Rebuild all target files ซ่ึงโปรแกรม Keil uVision3 จะทําการสั่งใหโปรแกรม Keil-CARM ทําการแปล
คําสั่งใหทันท ี

 

 
 

ซ่ึงหลังจากสั่งแปลโปรแกรมแลวไดผลถูกตองและไมเกิดขอผิดพลาดใดๆขึ้น (0 Error และ 0 
Warning) ก็ได Hex File ซ่ึงมีช่ือเหมือนกนักับชื่อของ Project File ที่สรางไว ซ่ึงผูใชสามารถนํา Hex 
File ดังกลาวไปทําการ Download ใหกับ MCU ไดทันท ี

 
ขอแนะนําในการ Initial MCU กอนเริ่มตนการทํางานของโปรแกรมหลัก 
 เพื่อใหการทํางานของ MCU มีประสิทธิภาพสูงสุด ทั้งในดานของความเร็วในการประมวลผลคําสั่ง 
และการทํางานควรกําหนดคาตางๆใหกับ MCU ดังตอไปนี้ 

- ควรกําหนดคา PLL ใหไดคา Processor Clock (cclk) = 58.9824MHz โดยในกรณีทีใ่ชคา XTAL เปน 
19.6608MHz ตองใหคา M(Multiply)=3 และ P(Divide)=2 และ FFCO =235.9296MHz 

- ควรกําหนดคา VPB Clock (pclk) ใหมีคา เปนครึ่งหนึ่งของ cclk หรือ 29.4912MHz 
- ควรกําหนดคา MAM Timing ใหมีคา 3 Cycle ของ cclk (MAMTIM = 0x03) 
- ควรกําหนดคา MAM Mode เปน Full Enable (MAMCR = 0x02) 
โดยการกําหนดคาตางๆดังกลาวขางตนนั้น สามารถทําได 2 วิธีคือ การเขียน Code คําสั่งในโปรแกรมที่เรา

เขียนขึ้นเองทัง้หมด หรือใชการ Copy ไฟลที่เปน Startup File ที่สรางไวเรียบรอยแลวมาใชงาน จากนั้นจึงสั่ง 
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Add Startup File เขามาใชงานใน Project ที่เราสรางขึ้น ซ่ึงการตรวจสอบและแกไขคาของ Startup File นั้น 
สามารถทําได 2 แบบ คือ เขาไปแกไข Code คําสั่งในไฟลตามความตองการ หรือ ใชการกําหนดคา Startup File 
จากหนาตางโปรแกรมของ Keil uVision3 เอง ซ่ึงเพื่อใหเกดิความสะดวกตอการใชงานขอแนะนําใหใชวิธีการ
แกไขเปลี่ยนแปลงคาจาก Keil uVision3 จะดีที่สุด  
 
การตรวจสอบคา Startup File 

 หนาที่ของ Startup File คือ บรรจุคําสั่งของโปรแกรมเริ่มตนการทํางานของ MCU กอนที่จะเริ่มตนมา
ทํางานตามคําสั่งที่เราเขียนขึน้ โดยโปรแกรมที่อยูใน Startup ไฟลจะทาํหนาที่ Initial การทํางานของ MCU ใน
สวนที่จําเปนกอน จากนั้นจึงจะกระโดดไปทํางานตามคําสั่งในโปรแกรมภาษาซีที่เราเขียนขึ้น ซ่ึงการเขาไป
ตรวจสอบคาของ Startup ไฟลสามารถทําไดโดย ใหเลือกคลิกที่ Tab ของไฟล Startup แลวเลือก “Expand All” 
ซ่ึงจะเหน็คาที่กําหนดไวใน Startup File ดงัรูป 
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แสดงการกําหนดคา Startup File สําหรับ LPC2214 
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ตัวอยาง Code ภาษาซีของ Keil-CARM สําหรับ Initial การทํางานของ LPC2214 
 

 สําหรับในกรณีที่ตองการเขยีนโปรแกรม Initial การทํางานของ MCU เอง ก็สามารถทําได โดยการเพิ่ม 
Code คําสั่งเขาไปในสวนเริม่ตนการทํางานของ Main Program ดังตัวอยาง 
 

// Initial PLL & VPB Clock For ET-JR ARM7 LPC2214 
// Start of Initial PLL for Generate Processor Clock  
// PLL Configuration Setup 
// X-TAL = 19.6608MHz   
// M(Multiply) = 3 
// P(Divide) = 2 
// Processor Clock(cclk) = M x OSC  
//                       = 3 x 19.6608MHz  
//                       = 58.9824MHz 
// FCCO = cclk x 2 x P 
//      = 58.9824 x 2 x P 
//      = 235.9296 MHz 
// VPB Clock(pclk) = 29.4912MHz 
// Start of Initial PLL for Generate Processor Clock  
PLLCFG &= 0xE0;     // Reset MSEL0:4 
PLLCFG |= 0x02;     // MSEL(PLL Multiply) = 3 
PLLCFG &= 0x9F;     // Reset PSEL0:1 
PLLCFG |= 0x20;     // PSEL(PLL Devide) = 2 
 
PLLCON &= 0xFC;     // Reset PLLC,PLLE 
PLLCON |= 0x01;     // PLLE = 1 = Enable PLL 
  
PLLFEED = 0xAA;     // Start Update PLL Config 
PLLFEED = 0x55; 
while (!(PLLSTAT & 0x00000400));  // Wait PLL Lock bit 
  
PLLCON |= 0x02;     // PLLC = 1 (Connect PLL Clock) 
PLLFEED = 0xAA;      // Start Update PLL Config 
PLLFEED = 0x55; 
 
VPBDIV &= 0xFC;     // Reset VPBDIV 
VPBDIV |= 0x02;     // VPB Clock(pclk) = cclk / 2 
// End of Initial PLL for Generate Processor Clock  
   
// Start of Initial MAM Function 
MAMCR = 0x00;     // Disable MAM Function 
MAMTIM = 0x03;     // MAM Timing = 3 Cycle of cclk 
MAMCR = 0x02;     // Enable MAM = Full Function 
// End of Initial MAM Function 
 
// Start of Main Function Here 
. 

 

แสดงตัวอยาง Code สําหรับ Initial การทํางานของ LPC2214 กอนเริ่มตนทํางานใน Main โปรแกรม 
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